BaseMap issues with newer leaflet version.

2 posts / 0 new
Last post
BillChappell
BaseMap issues with newer leaflet version.

Hi,

I noticed in your sample, you were using leaflet-0.7.5 and used layers: MQ.mapLayer(), as a basemap.

We are developing with the newer v1.0.0-beta2 version of leaflet.

When I tried to use this layer it screams "TypeError: this._adjustTilePoint is not a function
https://www.mapquestapi.com/sdk/leaflet/v2.s/mq-map.js?......Line 61 in firebug.

I am however able to use the standard Leaflet basemaps and see the traffic for my prototype.However I have to admit, I like your basemap better.Any idea of when you will be supporting the newer leaflet api?

Thanks..

 


Thomas.Horacek
Leaflet Beta
Hi Bill, I am the developer working on the MapQuest leaflet plugins. Thank you for the bug report! We are working on a bug fix release soon to address the _adjustTilePoint error you are seeing. However, we have not completed work around validation of our plugins with the the leaflet 1.0 beta yet. So at this time, the use of our plugins with leaflet 1.0 beta is a "use at your own risk" scenario, you might encounter additional bugs that could completely break the functionality of our plugins, like the one you reported. Thanks, Thomas