Error processing route request when calling open.mapquestapi.com/directions/v2/route

5 posts / 0 new
Last post
g.rouleau
Error processing route request when calling open.mapquestapi.com/directions/v2/route

Hello,

I've got an issue calling open.mapquestapi.com/directions/v2/route with xml data.

With the same Request, the response is sometimes 'statusCode 0' and sometimes 'statusCode 400'

The error details are :

    Error parsing XML from Request: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages

The complete call is :

open.mapquestapi.com/directions/v2/route?key=MYKEY&inFormat=xml&outFormat=xml&xml=<route><options><locale>fr_FR</locale><unit>k</unit><shapeFormat>cmp</shapeFormat><generalize>0</generalize></options><locations><location><latLng><lat>47.1963136</lat><lng>-1.4899418</lng></latLng></location><location><latLng><lat>47.2058325</lat><lng>-1.5136918</lng></latLng></location></locations></route>

The body request formatted is :

<route>

    <options>

        <locale>fr_FR</locale>

        <unit>k</unit>

        <shapeFormat>cmp</shapeFormat>

        <generalize>0</generalize>

    </options>

    <locations>

        <location>

            <latLng>

                <lat>47.207406</lat>

                <lng>-1.514098</lng>

            </latLng>

        </location>

        <location>

             <latLng>

                  <lat>47.197154717337</lat>

                  <lng>-1.49449393976486</lng>

             </latLng>

        </location>

     </locations>

</route>

The body response with statusCode 400 is :

<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<response>
<info>
<statusCode>400</statusCode>
<messages>
<message>Error processing route request: </message>
<message>Error parsing XML from Request: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages Nested exception: Could not load any resource bundle by com.sun.org.apache.xerces.internal.impl.msg.SAXMessages,  Please see the documentation for the Directions Service at http://open.mapquestapi.com/directions/ for details on correctly formatting requests.</message>
</messages>
<copyright>
<imageUrl>http://api.mqcdn.com/res/mqlogo.gif</imageUrl>
<imageAltText>© 2021 MapQuest, Inc.</imageAltText>
<text>© 2021 MapQuest, Inc.</text>
</copyright>
</info>
<routeError>
<errorCode>0</errorCode>
<message/>
</routeError>
<route />
</response>

Thanks for help!!


MapQBrianCoakley
Are you still seeing this
Are you still seeing this error?   If so, do you also see it using www.mapquestapi.com rather than open.mapquestapi.com?

g.rouleau
Hello, i get a new key to try

Hello, i get a new key to try mapquestapi.com. It seems to work with mapquestapi but can you tell me why it doesn't work anymore with open.mapquestapi?

Is it going to work again?

Thx 


g.rouleau
I still seeing this error and

I still seeing this error and i also got it on optimizedroute call

I can try on mapquestapi.com cause i don't have key for it

Thanks to tell me if open.mapquestapi.com got problem?


MapQBrianCoakley
This usually means there is a
This usually means there is a machine out of sync and this self-corrects. If you're still seeing the issue, can you post a sample request so we can take a deeper look?