Inconsistent results returned for same address

6 posts / 0 new
Last post
jimromano
Inconsistent results returned for same address

I'm using http://www.mapquestapi.com/geocoding/v1/ to geocode the following address:

4105 Ryan Way South 
Winston-Salem, NC 27106

The webservice returns the following:

Latitude: 36.137541, Longitude: -80.343198, Quality: B3AAA

When I use the MapQuest Lat/Lng Finder online tool at https://developer.mapquest.com/documentation/tools/latitude-longitude-fi..., it returns the following:

Latitude: 36.135679, Longitude: -80.335719, Quality: P1AAA

Why such a discrepancy?  We use the quality code in our eligibility decision, and this is impacting that decision making.


MQBrianCoakley
The single line geocoder is
The single line geocoder is having issues determining whether the "South" text is the end of the street or the beginning of the city. Change it to "S" and it works fine. It works great in the Lat/Lng finder with "South" since the street is already parsed correctly.

jimromano
Similar issue with a new

Similar issue with a new address, 44 Larking Pond Rd S, West Kingston, RI 02892. 


MQBrianCoakley
I'm not seeing inconsistent
I'm not seeing inconsistent results in several tests. I get P1BBA in the same locations each time. The correct road name is Larkin Pond Rd S.

jimromano
Inconsistent results returned for same address

The Lat/Lng Finder Tool returns a different (highest) quality code for the address.


MQBrianCoakley
Are you still seeing this
Are you still seeing this behavior now? If so, where is the request originating from geographically?