Unable to route to any locations

51 posts / 0 new
Last post
freek-tentoo
Unable to route to any locations

I used mapquest directions api to calculate the route between 2 coordinate points. It works normally until last week, it suddenly failed to return the route with the follow error:

{
    "route": {
        "routeError": {
            "errorCode": 100,
            "message": ""
        }
    },
    "info": {
        "statuscode": 500,
        "copyright": {
            "imageAltText": "© 2018 MapQuest, Inc.",
            "imageUrl": "http://api.mqcdn.com/res/mqlogo.gif",
            "text": "© 2018 MapQuest, Inc."
        },
        "messages": [
            "Error processing request: Error invoking doRoute: Error invoking doRoute: Server returned HTTP response code: 500 for URL: http://route-open.cloud.mapquest.com:80/mq/mqserver.dll?e=0&DoRoute.17="
        ]
    }
}

 

Example of my request:

{"locations":["-4.130025, -40.584869","-4.315943, -40.709496"],"options":{"ambiguities":"ignore","routeType":"shortest","doReverseGeocode":"false","enhancedNarrative":"false","avoidTimedConditions":"false","fullShape":"true","unit":"k"}}

 

This is very frustrating as it doesn't return any useful information at all!


istef
Unable to route to any locations

Same here.

Map view and Geocoding work perfectly.

Error 500 seems to appear randomly (i'm testing 'optimizedRoute').

Hope this could help.

Regards


necrom9608
I can't get directions

I can't get directions anymore too, there seems to be a general problem.

Whatever I try, I always get the same error:

 

<response>
<info>
<statusCode>500</statusCode>
<messages>
<message>Error processing request: Error invoking doRoute: Error invoking doRoute: Server returned HTTP response code: 500 for URL: http://route-open.cloud.mapquest.com:80/mq/mqserver.dll?e=0&amp;DoRoute.17=</message>
</messages>
<copyright>
<imageUrl>https://api-s.mqcdn.com/res/mqlogo.gif</imageUrl>
<imageAltText>© 2018 MapQuest, Inc.</imageAltText>
<text>© 2018 MapQuest, Inc.</text>
</copyright>
</info>
<routeError>
<errorCode>100</errorCode>
<message/>
</routeError>
<route/>
</response>


necrom9608
This is what I tried:

MQBrianCoakley
Hi Everyone,
Hi Everyone, We are investigating the issue now. Can you post a sample route that is failing for you? Are all of your route locations outside North America? Are all route requests originating from outside North America? What percentage of routes are failing? Thanks,

groundtruth
Routes in Australia failing

Example (KEY REMOVED)

https://open.mapquestapi.com/directions/v2/route?from=-36.74879670848811...

{"route":{"routeError":{"errorCode":100,"message":""}},"info":{"statuscode":500,"copyright":{"imageAltText":"© 2017 MapQuest, Inc.","imageUrl":"http://api.mqcdn.com/res/mqlogo.gif","text":"© 2017 MapQuest, Inc."},"messages":["Error processing request: Error invoking doRoute: Error invoking doRoute: route.open.mapquest.com"]}}


istef
Yes, all locations are in

Yes, all locations are in Europe in my case.

Percentage depends on time of the day:

5 hours ago: ca 25%

2 hours ago about 100%

last 30 min: ca 50%

 


PatrikSystematiq
Example of failing request,

Example of failing request, with key replaced:

http://www.mapquestapi.com/directions/v2/route?key=xxxxxxxxxxxxx&inForma...

All locations are in Europe (Sweden) and all requests are made from there also.

 


freek-tentoo
- Most of my locations are in

- Most of my locations are in Belgium

This is another error I get:

{
    "route": {
        "distance": 0,
        "computedWaypoints": [],
        "routeError": {
            "errorCode": 202,
            "message": ""
        },
        "realTimeAlternatePercentSavingsThreshhold": "",
        "formattedTime": "00:00:00",
        "realTimeAlternateTimeSavingsThreshhold": "",
        "hasSeasonalClosure": false,
        "hasCountryCross": false,
        "mapState": {
            "center": {
                "lng": 0,
                "lat": 0
            },
            "width": 512,
            "scale": 443744032,
            "height": 512
        },
        "legs": [],
        "options": {
            "arteryWeights": [],
            "cyclingRoadFactor": 1,
            "timeType": 0,
            "useTraffic": false,
            "returnLinkDirections": false,
            "countryBoundaryDisplay": true,
            "enhancedNarrative": false,
            "locale": "en_US",
            "tryAvoidLinkIds": [],
            "drivingStyle": 2,
            "doReverseGeocode": false,
            "generalize": 0,
            "mustAvoidLinkIds": [],
            "sideOfStreetDisplay": true,
            "routeType": "SHORTEST",
            "avoidTimedConditions": false,
            "routeNumber": 0,
            "shapeFormat": "raw",
            "maxWalkingDistance": -0.621371,
            "destinationManeuverDisplay": true,
            "transferPenalty": -1,
            "narrativeType": "text",
            "walkingSpeed": -0.621371,
            "urbanAvoidFactor": -1,
            "stateBoundaryDisplay": true,
            "unit": "K",
            "highwayEfficiency": 22,
            "maxLinkId": 0,
            "maneuverPenalty": -1,
            "avoidTripIds": [],
            "filterZoneFactor": -1,
            "manmaps": "true"
        },
        "hasFerry": false,
        "hasTollRoad": false,
        "hasBridge": false,
        "hasTunnel": false,
        "hasHighway": false,
        "sessionId": "",
        "maxRoutes": "",
        "realTime": -1,
        "fuelUsed": 0,
        "timeOverage": "",
        "locations": [
            {
                "dragPoint": false,
                "displayLatLng": {
                    "lng": 4.703615,
                    "lat": 50.877844
                },
                "adminArea4": "",
                "adminArea5": "",
                "postalCode": "",
                "adminArea1": "",
                "adminArea3": "",
                "type": "s",
                "sideOfStreet": "N",
                "geocodeQualityCode": "XXXXX",
                "adminArea4Type": "County",
                "linkId": 2760159,
                "street": "",
                "adminArea5Type": "City",
                "geocodeQuality": "LATLNG",
                "adminArea1Type": "Country",
                "adminArea3Type": "State",
                "latLng": {
                    "lng": 4.703615,
                    "lat": 50.877844
                }
            },
            {
                "dragPoint": false,
                "displayLatLng": {
                    "lng": 4.461023,
                    "lat": 50.84926
                },
                "adminArea4": "",
                "adminArea5": "",
                "postalCode": "",
                "adminArea1": "",
                "adminArea3": "",
                "type": "s",
                "sideOfStreet": "N",
                "geocodeQualityCode": "XXXXX",
                "adminArea4Type": "County",
                "linkId": 10715401,
                "street": "",
                "adminArea5Type": "City",
                "geocodeQuality": "LATLNG",
                "adminArea1Type": "Country",
                "adminArea3Type": "State",
                "latLng": {
                    "lng": 4.461023,
                    "lat": 50.84926
                }
            }
        ],
        "time": 0,
        "hasUnpaved": false,
        "locationSequence": [
            0,
            1
        ]
    },
    "info": {
        "statuscode": 602,
        "copyright": {
            "imageAltText": "© 2018 MapQuest, Inc.",
            "imageUrl": "http://api.mqcdn.com/res/mqlogo.gif",
            "text": "© 2018 MapQuest, Inc."
        },
        "messages": [
            "Unable to calculate route."
        ]
    }
}

My request:

{"locations":["50.8778449,4.7036151","50.84926,4.4610236"],"options":{"ambiguities":"ignore","routeType":"shortest","doReverseGeocode":"false","enhancedNarrative":"false","avoidTimedConditions":"false","fullShape":"true","unit":"k"}}

I think this one is another issue but I'm wondering why is it unable to route


MQBrianCoakley
Hopefully nobody is seeing
Hopefully nobody is seeing this anymore. The route team found an issue with a small subset of the route environment and pushed out a breakfix. You should be good to go now.

istef
I confirm all is ok this

I confirm all is ok this morning!

Thank you very much.

 


MQBrianCoakley
Good to know. Thanks for
Good to know. Thanks for confirming.

Drahtesel85
Pocket Earth Pro

Hi there, this is probably not the right place to ASK for help, but I Googled the error and this came up. I use the pocket earth pro app to navigate during my world travel by bicycle  over the last months there were hardly any complications but now I can’t get directions anymore iOS app won’t calculate routes anymore  not one  for me this is a huge problem because I rely on this app entirely  can anyone help? Many thanks in advance

 

 

 

 


MQBrianCoakley
Sorry, I'm not sure where to
Sorry, I'm not sure where to send you for Pocket Earth help. Maybe their forum would help. It doesn't look like they're using MapQuest since they have offline functionality.

cedar
I'm still experiencing this problem.

The problem has been happening since 3 days ago

API : http://open.mapquestapi.com/directions/v2/optimizedroute?key=KEY&json={%22locations%22:[%22Denver,CO%22,%22Westminster,CO%22,%22Boulder,CO%22]}

and

http://open.mapquestapi.com/directions/v2/route?key=KEY&from=37.2559,127...

 

result: {
  "route": {
    "routeError": {
      "errorCode": 100,
      "message": ""
    }
  },
  "info": {
    "statuscode": 500,
    "copyright": {
      "imageAltText": "© 2017 MapQuest, Inc.",
      "imageUrl": "http://api.mqcdn.com/res/mqlogo.gif",
      "text": "© 2017 MapQuest, Inc."
    },
    "messages": Array[1][
      "Error processing request: Error invoking doRoute: Error invoking doRoute: route.open.mapquest.com"
    ]
  }
}

What should I do?

 

 


MQBrianCoakley
Both of those requests work
Both of those requests work great for me with my test key and with both of your keys. Maybe there is something getting cached and needs to be cleared. Try putting the request into a browser and change something slightly to get around any weird caching.

pande
Still not working need assistance thx

Error processing request: Error invoking doRoute: Error invoking doRoute: route.open.mapquest.com

https://open.mapquestapi.com/directions/v2/route?key=&json={%22locations%22:[{%22latLng%22:{%22lat%22:%22-6.4244659%22,%22lng%22:%22106.727939%22}},{%22latLng%22:{%22lat%22:%22-6.4273248%22,%22lng%22:%22106.7269653%22}},{%22latLng%22:{%22lat%22:%22-6.429809%22,%22lng%22:%22106.7210704%22}},{%22latLng%22:{%22lat%22:%22-6.4316068%22,%22lng%22:%22106.7146047%22}},{%22latLng%22:{%22lat%22:%22-6.4985989%22,%22lng%22:%22106.714437%22}},{%22latLng%22:{%22lat%22:%22-6.4335757%22,%22lng%22:%22106.7125913%22}},{%22latLng%22:{%22lat%22:%22-6.4319998%22,%22lng%22:%22106.7126266%22}},{%22latLng%22:{%22lat%22:%22-6.4351434%22,%22lng%22:%22106.7076023%22}},{%22latLng%22:{%22lat%22:%22-6.4355472%22,%22lng%22:%22106.7063873%22}},{%22latLng%22:{%22lat%22:%22-6.4362513%22,%22lng%22:%22106.7051809%22}},{%22latLng%22:{%22lat%22:%22-6.4429308%22,%22lng%22:%22106.6929383%22}},{%22latLng%22:{%22lat%22:%22-6.4436045%22,%22lng%22:%22106.6918664%22}},{%22latLng%22:{%22lat%22:%22-6.4659532%22,%22lng%22:%22106.7129599%22}},{%22latLng%22:{%22lat%22:%22-6.4680142%22,%22lng%22:%22106.7089058%22}},{%22latLng%22:{%22lat%22:%22-6.4475173%22,%22lng%22:%22106.732083%22}},{%22latLng%22:{%22lat%22:%22-6.4489408%22,%22lng%22:%22106.732494%22}},{%22latLng%22:{%22lat%22:%22-6.4489408%22,%22lng%22:%22106.732494%22}},{%22latLng%22:{%22lat%22:%22-6.4513252%22,%22lng%22:%22106.7358869%22}},{%22latLng%22:{%22lat%22:%22-6.4525968%22,%22lng%22:%22106.7366658%22}},{%22latLng%22:{%22lat%22:%22-6.4389147%22,%22lng%22:%22106.7350741%22}},{%22latLng%22:{%22lat%22:%22-6.4389147%22,%22lng%22:%22106.7350741%22}},{%22latLng%22:{%22lat%22:%22-6.4313188%22,%22lng%22:%22106.7512926%22}}],%22options%22:{%22shapeFormat%22:%22cmp6%22,%22generalize%22:0}}

 


MQBrianCoakley
Are you still seeing this
Are you still seeing this error? I copied the request above, inserted my key, and it worked great. If you're still seeing it, where, geographically, is the request originating from?

pande
Hi, From Indonesia.

Hi,

From Indonesia.


jasond
Still seeing this problem

Two of our users contacted us with routing issues this week. I asked one to enter the URL that I use into his web browser and it gave the "Error invoking doRoute" message. The URL used a test key I created this week. The URL works fine for me. Both users are in Califormia.


JoeM
We are having the "Error

We are having the "Error invoking doroute" issue, as well.  It appears to be regional.  Our webserver in VA can call the API just fine.  Our webserver in UT gets the error.  We've tested to have both servers make the exact same call.


geomagik
Getting same error

Also experiencing this issue.  For example using the sample given in the documentation fails. (Replacing KEY with our key of course):

http://open.mapquestapi.com/directions/v2/route?key=KEY&from=Clarendon%2...


MQBrianCoakley
Thanks for the additional
Thanks for the additional information. This has been forwarded on to the teams to assess.

jasond
It's been a week, any update?

It's been a week, any update?


MQBrianCoakley
The Clarendon to Glebe
The Clarendon to Glebe example in the documentation is incorrect due to the destination address not being found and it routes to a default location - the center of the US. All other routes should be successful though. Are other routes failing for you?

jasond
My report is from users, not

My report is from users, not the documentation. We use GPS coordinates, not addresses. I just heard from one user that it is working now, but I haven't heard from another. We need to know if the developers fixed something. If they didn't, that is concerning, because it means the issue could happen again. Again, as at least a couple of us reported, the problem appears to be "regional". The exact same query can succeed in one state and fail in another.
 


MQBrianCoakley
There was an issue when this
There was an issue when this thread first started. There was an update to the infrastructure and a very small percentage of users were routed through a path that was misconfigured. The development and operations teams eventually found the misconfiguration and there was a breakfix done. We should not be seeing that issue anymore.

jasond
I see there was a breakfix on

I see there was a breakfix on Jan 11, but there were several posts after that (including mine). Was there another breakfix? Just want to be clear.


MQBrianCoakley
We saw a few users with
We saw a few users with issues from west coast locations that we believe were due to a CenturyLink issue. CenturyLink resolved the issue and the MapQuest users' issues were resolved. MapQuest made no changes for the CenturyLink issue.

jasond
Thanks Brian. Have a good

Thanks Brian. Have a good week!


CDA
​Getting this error again

​Getting this error again today, locations in the UK


CDA
​Working again now thanks :)

​Working again now thanks :)


MQBrianCoakley
There has been a routing on
There has been a routing on and off today and the team is working on a longer term fix at the moment. Sorry for the inconvenience.

digitalfiledevel
Routing Problems

We are experiencing routting problems since yesterday. When do you expect to fix the problem?

Thanks


MQBrianCoakley
The directions api should be
The directions api should be back up and running as of 5/17. There are some lingering session errors for route outside the US. The teams are working on this and should have a solution soon. Sorry for the inconvenience.

icross
Routing problems for Eastern Europe

Hi, i'm getting the same error for any locations in Eastern Europe: Error processing request: Error invoking doRoute: Error invoking getRouteShapeFromSession.  Server returned HTTP response code: 500 for URL: http://sessionread-b2b-production.cloud.mapquest.com:80/mq/mqserver.dll?...


norcox
Hi, My users are experiencing

Hi, My users are experiencing the same issue.  Same 500 response code for the same  http://sessionread-b2b-production.cloud.mapquest.com:80/mq/mqserver.dll

All addresses in UK (Scotland).


MQBrianCoakley
There are some lingering
There are some lingering session errors for route outside the US as a result of the 5/17 issue. The teams are working on this and should have a solution soon. Sorry for the inconvenience.

compliancepublishing
it is timing out at random times

We are getting a time-out with random records.  Are there problems today?


MQBrianCoakley
Inside the US you should be
Inside the US you should be fine. Outside the US you may get some session errors. The team is working on a fix for this they hope to have out quickly. Sorry for the inconvenience.

necrom9608
I'm still getting an error:

I'm still getting an error:

<response>
    <info>
        <statusCode>500</statusCode>
        <messages>
            <message>Error processing request: Error invoking doRoute: Error invoking getRouteShapeFromSession.  Server returned HTTP response code: 500 for URL: http://sessionread-b2b-production.cloud.mapquest.com:80/mq/mqserver.dll?...
        </messages>
        <copyright>
            <imageUrl>http://api.mqcdn.com/res/mqlogo.gif</imageUrl>
            <imageAltText>© 2018 MapQuest, Inc.</imageAltText>
            <text>© 2018 MapQuest, Inc.</text>
        </copyright>
    </info>
    <routeError>
        <errorCode>100</errorCode>
        <message />
    </routeError>
    <route />
</response>


MQBrianCoakley
You should be good to go now.
You should be good to go now.

FerryPak
fullShape=true broken

The fullShape=true routing still seems to be broken (this is in Poland):

https://www.mapquestapi.com/directions/v2/route?key=&from=52.561389,20.5...

The fullShape=false option does still work: but this is very coarse and only shows the turns.


MQBrianCoakley
Does it work if you use
Does it work if you use generalize=0?

FerryPak
Yep, this does work, thanks!

Yep, this does work, thanks!


MQBrianCoakley
Cool. You're welcome.
Cool. You're welcome.

k.adamczyk
Today routing stopped working

Today routing stopped working for us. We're getting the same as above:

{"route":{"routeError":{"errorCode":100,"message":""}},"info":{"statuscode":500,"copyright":{"imageAltText":"© 2018 MapQuest, Inc.","imageUrl":"http://api.mqcdn.com/res/mqlogo.gif","text":"© 2018 MapQuest, Inc."},"messages":["Error processing request: Error invoking doRoute: Error invoking doRoute: route-open-production.cloud.mapquest.com"]}}

Can you please check it? It's quite important for us.


MQBrianCoakley
Thanks for the heads up. I
Thanks for the heads up. I recreated the issue with my key and forwarded this on to the team to address. You should be able to get around it by using www.mapquestapi.com rather than open.mapquestapi.com.

MQBrianCoakley
You should be good to go now.
You should be good to go now.

mdweather
Search box for U.S. addresses

Search box for U.S. addresses does not work for any location on my home PC with Windows10 and Firefox browser!  Problem started today.  Cleared cache and history and still doesn't work.  Sometimes a "404" code error shows up.  I need Mapquest for my business.  this has never occurred before in years of use with same computer. Please help!
 


MQBrianCoakley
If you're using the MapQuest
If you're using the MapQuest developer tools, you can post the request being made by your application here.   If you're using MapQuest.com then you can use the https://help.mapquest.com site to report issues. That team knows current issues with the MapQuest end user products like mobile apps and MapQuest.com.